Serendipity requires a PHP version >= 5.3 - you are running a lower version (5.2.17) and need to upgrade your PHP version. Most providers offer you to switch to newer PHP versions through their admin panels or .htaccess directives.